주 메뉴 열기

두리틀 (프로그래밍 언어)

두리틀(Dolittle, ドリトル 도리토루[*])은 2000년 일본 히토츠바시 대학 가네무네 스스무(兼宗進) 교수와 츠쿠바 대학 구노 야스시(久野靖) 교수가 만든 교육용 프로그래밍 언어이다. [1]LOGO의 거북이 그래픽을 도입하였고 객체지향적인 특징도 가지고 있다.[2] 한글판은 대한민국 고려대학교 이원규 교수가 만들었다.

두리틀 (ドリトル)
패러다임멀티 패러다임: 객체 지향
설계자KANEMUNE Susumu (兼宗進)
개발자오사카전기통신대학
최근 버전2.3
최근 버전 출시일2011년 9월
영향을 받은 언어
로고

개요편집

두리틀은 일본어 어순을 따르므로 모국어의 어순이 일본어 어순과 비슷한 대한민국의 교육현장에 적용하기에 알맞다. 또한 두리틀은 자국어를 지원할 뿐 아니라 한국어로 프로그래밍을 할 수 있으며 텍스트기반으로 소스코딩을 기술한다. 또한 객체지향적 언어로 객체를 활용하여 단기간 학습을 통해 프로그래밍을 완성하는데 효율적인 프로그래밍 언어이다.

예제 프로그램편집

 かめ太=タートル!作る。
 カメ=タートル! 作る。
 時計=タイマー! 作る 0.1秒 間隔 500回 回数。 時計! 「かめ太! 10 歩く」 実行。
 左=ボタン!”左”作る。 左:動作=「かめ太! 20 左回り」。
 右=ボタン!”右”作る。 右:動作=「かめ太! 10 右回り」。

참조편집

  1. 《두리틀로 배우는 프로그래밍》. 2006, 휴먼사이언스. ISBN 9788993712032.
  2. 〈객체지향형 교육용 프로그래밍 언어 '두리틀(Dolittle)'의 수학 교육 활용 방안〉. 김경미. 2004.

외부 링크편집