Rhymix

(라이믹스에서 넘어옴)

라이믹스(Rhymix)는 XpressEngine를 포크[1]하여 시작한 PHP 저작물 관리 시스템 (CMS, Contents Management System)이다. 사용자 커뮤니티를 중심으로 기존 사용자들의 목소리를 적극 반영하고 미래를 타인이 아닌 스스로의 손으로 결정해야 한다는 취지로 시작된 오픈소스 프로젝트로, 라이믹스(Rhymix)라고 부른다.

Rhymix
개발자Rhymix 개발팀
안정화 버전
2.0
저장소라이믹스 GitHub 저장소
프로그래밍 언어PHP, JavaScript
운영 체제리눅스, 유닉스 계열, 윈도우
종류저작물 관리 시스템 오픈 소스 게시판 블로그 소프트웨어
라이선스GPLv2
웹사이트Rhymix 공식 사이트

역사 편집

XpressEngine을 개발하고 있던 팀이 사용자들의 의견에 귀를 기울이지 않는 빈도가 높아지더니, 2015년 말에는 급기야 기존 XE와는 호환이 전혀 안되는 XE3라는 CMS를 내놓자, 기존 사용자들을 중심으로 자구책을 마련하기 시작했다. 당시 네이버의 지원을 받아 개발되던 XE를 포크하여 순수 오픈소스 프로넥트로 개발을 이어간다는 것은 쉬운 결정은 아니었으나, 6개월간의 논의 끝에 2015년 말에 XE를 포크하여 라이믹스(Rhymix)라는 새로운 프로젝트를 시작하기에 이른다.

라이믹스는 XE의 히스토리에 들어간 노력과 갈등의 역사를 그대로 모두 인정하고 계승하며, 잘못된 것은 고치고 큰 틀은 계속 유지했다. 언젠가 XE 개발이 중단되는 시점에는 라이믹스가 XE의 자리를 이어받아야 하기 때문이었다.

라이믹스 개발자들은 기존 XE를 획기적으로 바꾸는데 집중하면서도 사용자들과의 의사소통도 게을리 하지 않았다. 라이믹스 프로젝트는 활발하고 꾸준히 진행되어 2020년 12월 18일에 라이믹스 5주년을 맞아 2.0 정식 버전이 발표되었다. 라이믹스 2.0은 PHP 8.x 지원 및 코어 내부적으로 기존 라이믹스와 XE에 비해 많은 부분이 변화 및 발전하였다.

버전 편집

버전 배포일 마지막 배포일 내용
XE 1.0 ~ 1.3 2008년 2월 28일 2009년 12월 21일 모듈,위젯,애드온 개념 도입
XE 1.4 2010년 1월 20일 2011년 9월 2일 안정화된 XE 시기
XE 1.5 2011년 10월 27일 2013년 3월 8일 UI 및 구조 변경
XE 1.7 2013년 2월 21일 2015년 3월 30일 메뉴 사이트맵 도입
XE 1.8 2015년 4월 8일 2017년 10월 19일 CKEditor 및 HTML5 적용
Rhymix 1.8 2015년 12월 18일 2017년 10월 19일 XE 1.8.15 포크
Rhymix 1.9 2017년 11월 30일 2020년 8월 29일 라이믹스 구조 개발. XE 1.9~1.11 흡수
Rhymix 2.0 2020년 12월 18일 2022년 12월 21일 DB연동 등을 강화한 메이저 업그레이드
Rhymix 2.1 2023년 예정 - 기능 추가[2]

설치 환경 편집

Rhymix 2.0 이상을 설치하려면 다음과 같은 조건이 필요하다.

  • PHP 7.2 이상. PHP 7.4 이상 권장하며 PHP 8.x 지원함
  • MariaDB 10.3 이상 또는 MySQL 5.7 이상[3]
  • 필요 PHP 모듈 : common, curl, gd, mbstring, mysql[4], xml, opcache, apcu, zip, jason[5], openssl[6]
  • 선택 PHP 모듈 : exif[7], fileinfo[8]

각주 편집

  1. 소프트웨어 개발(Software Development)에서 사용하는 용어로, 수정 및 재배포를 허용하는 오픈소스 소프트웨어의 소스코드를 가져와서 새로운 개발을 시작하는 행위를 포크(Fork)라고 한다.
  2. 라이믹스 2.1에서는 2.0과는 달리 내부 구조가 급격하게 바뀌지는 않으며 그동안 미뤄왔던 기능들이 추가될 계획이다.
  3. MariaDB 10.2 이하 및 MySQL 5.0.7 ~ 5.6 버전도 사용은 가능하지만 End of Life가 지난 버전을 사용하는 것은 바람직하지 않다.
  4. common이나 mysql을 설치하면 pdo 모듈이 함께 설치되는 것이 일반적인데, 만약 설치되지 않으면 pdo 모듈을 추가로 설치해줘야 한다. 라이믹스 2.0 이상부터는 API로 MySQLi를 사용하지 않고 PDO_MySQL를 사용하기 때문에 pdo 모듈이 필요하다.
  5. PHP 8.0 부터는 json이 php 자체에 내장되어 있기 때문에, 더 이상 별도의 extension은 설치할 필요가 없다.
  6. 과거에는 mcrypt를 사용하기도 했으나 PHP 7.2 부터는 openssl을 사용한다. PHP 7.2에서 mcrypt 모듈이 제외되었기 때문이다. openssl은 PHP 자체에 내장되어 있기 때문에 별도의 extension은 설치할 필요가 없다.
  7. exif 모듈은 이미지 자동회전 기능에 필요하다.
  8. fileinfo 모듈은 첨부파일 보안검사를 할 경우에 필요하다.

같이 보기 편집

외부 링크 편집